build_mingw{32,64}.sh: vamp cross-compilation is broken, refuse to run scripts (see #2)
authorPaul Brossier <piem@piem.org>
Mon, 13 Feb 2017 21:45:05 +0000 (22:45 +0100)
committerPaul Brossier <piem@piem.org>
Mon, 13 Feb 2017 21:45:05 +0000 (22:45 +0100)
build_mingw32.sh
build_mingw64.sh

index 0c136c7..9a46b6f 100755 (executable)
@@ -2,6 +2,10 @@
 
 # cross compile vamp-aubio-plugins using mingw32 toolchain
 
 
 # cross compile vamp-aubio-plugins using mingw32 toolchain
 
+echo "ERROR: This script does not produce a binary loadable by sonic visualiser."
+echo "Comment the following line to run it anyway."
+exit 1
+
 . $PWD/VERSION
 VAMP_AUBIO_VERSION=$VAMP_AUBIO_MAJOR_VERSION.$VAMP_AUBIO_MINOR_VERSION.$VAMP_AUBIO_PATCH_VERSION$VAMP_AUBIO_VERSION_STATUS
 
 . $PWD/VERSION
 VAMP_AUBIO_VERSION=$VAMP_AUBIO_MAJOR_VERSION.$VAMP_AUBIO_MINOR_VERSION.$VAMP_AUBIO_PATCH_VERSION$VAMP_AUBIO_VERSION_STATUS
 
index 6c1b721..a2964eb 100755 (executable)
@@ -2,6 +2,10 @@
 
 # cross compile vamp-aubio-plugins using mingw32 toolchain
 
 
 # cross compile vamp-aubio-plugins using mingw32 toolchain
 
+echo "ERROR: This script does not produce a binary loadable by sonic visualiser."
+echo "Comment the following line to run it anyway."
+exit 1
+
 . $PWD/VERSION
 VAMP_AUBIO_VERSION=$VAMP_AUBIO_MAJOR_VERSION.$VAMP_AUBIO_MINOR_VERSION.$VAMP_AUBIO_PATCH_VERSION$VAMP_AUBIO_VERSION_STATUS
 
 . $PWD/VERSION
 VAMP_AUBIO_VERSION=$VAMP_AUBIO_MAJOR_VERSION.$VAMP_AUBIO_MINOR_VERSION.$VAMP_AUBIO_PATCH_VERSION$VAMP_AUBIO_VERSION_STATUS